Suche im Forum:
Suchen


« Vorheriges Thema anzeigen :: Nächstes Thema anzeigen »  
Autor Nachricht
Beitrag04.08.2009 um 12:28 (UTC)    
Titel: [noch offen] Wiederholung in Tabelle

Grüßt euch HP-bastler ^^

ich bin beim coden soeben auf ein kleines Problem gestoßen und kann mir nicht erklären wo das Problem liegt!? xD

Der code meiner Tabelle sieht so aus:

Code:
<div align="center">
<body marginheight="0" topmargin="0" leftmargin="0" marginwidth="0" BGCOLOR="#000000">

   
<table cellspacing="0" cellpadding="0" width="860" height="85" border="0">
<tr>
<td background="http://img.webme.com/pic/m/muchloads/award-oben.png"> </td>
</tr>
</table>

<table cellspacing="0" cellpadding="0" width="860" height="330" border="0">
<tr>
<td width="86" height="330" background="http://img.webme.com/pic/m/muchloads/award-links.png"> </td>

<td Width="271" height="330" background="http://img.webme.com/pic/m/muchloads/award-multimediahome.png"> <a target="_blank" href="http://www.multimediahome.de.tl"><img border="0" src="http://img.webme.com/pic/m/muchloads/award-multimediahome.png"/> </td>

<td width="178" height="330" background="http://img.webme.com/pic/m/muchloads/award-mitte.png"> </td>

<td width="146" height="330" background="http://img.webme.com/pic/m/muchloads/award-checked.png"> <a target="_blank" href="http://www.homepage-check.de.tl/muchloads.htm"><img border="0" src="http://img.webme.com/pic/m/muchloads/award-checked.png"/> </td>

<td width="179" height="330" background="http://img.webme.com/pic/m/muchloads/award-rechts.png"> </td>
  </tr>
</table>


<table cellspacing="0" cellpadding="0" width="860" height="85" border="0">
<tr>
 <td background="http://img.webme.com/pic/m/muchloads/award-unten.png"> </td>
</tr>
</table>
</body>
</div>


Und auf der HP sieht das ganze dann so aus:
http://muchloads.de.tl/Titel-der-neuen-Seite.htm

Wie zu sehen ist, wiederholt sich ein ganz kleiner Teil der oberen Tabelle in dem unteren Teil der Tabelle!
Wo ist der codingfehler!? oÔ

Würd mich über rückmeldung sehr freuen! Smile

mfg, ML
______________


Zuletzt bearbeitet von muchloads am 05.08.2009, 08:50, insgesamt 2-mal bearbeitet
Beitrag04.08.2009 um 21:27 (UTC)    
Titel:

Hallo,

das Problem dabei war, dass du in manchen Spalten einen Link geöffnet hast, ihn aber nicht geschlossen hast. Zwei mal. Hier mal ein Beispiel, was fehlte (rot markiert):
Beispiel hat Folgendes geschrieben:
<td Width="271" height="330" background="http://img.webme.com/pic/m/muchloads/award-multimediahome.png"> <a target="_blank" href="http://www.multimediahome.de.tl"><img border="0"

src="http://img.webme.com/pic/m/muchloads/award-multimediahome.png"/></a> </td>



Hier dein komplett verbesseter Code (habe den Body-Tag mal rausgenommen - kannst du ja dann beliebig innerhalb dessen einfügen):
Code:
<div align="center">
   <table cellspacing="0" cellpadding="0" width="860" height="85" border="0">
         <tr>
            <td background="http://img.webme.com/pic/m/muchloads/award-oben.png"> </td>
         </tr>
   </table>

   <table cellspacing="0" cellpadding="0" width="860" height="330" border="0">
         <tr>
            <td width="86" height="330" background="http://img.webme.com/pic/m/muchloads/award-links.png"> </td>
            <td Width="271" height="330" background="http://img.webme.com/pic/m/muchloads/award-multimediahome.png">
               <a target="_blank" href="http://www.multimediahome.de.tl"><img border="0" src="http://img.webme.com/pic/m/muchloads/award-multimediahome.png"/></a>
            </td>
            <td width="178" height="330" background="http://img.webme.com/pic/m/muchloads/award-mitte.png"> </td>
            <td width="146" height="330" background="http://img.webme.com/pic/m/muchloads/award-checked.png">
               <a target="_blank" href="http://www.homepage-check.de.tl/muchloads.htm"><img border="0" src="http://img.webme.com/pic/m/muchloads/award-checked.png"/></a>
            </td>
            <td width="179" height="330" background="http://img.webme.com/pic/m/muchloads/award-rechts.png"> </td>
         </tr>
   </table>

   <table cellspacing="0" cellpadding="0" width="860" height="85" border="0">
         <tr>
            <td background="http://img.webme.com/pic/m/muchloads/award-unten.png"> </td>
         </tr>
   </table>
</div>


Ich hoffe, ich konnte helfen Wink


Liebe Grüße,

Jan aka "Asgar"
______________
Beitrag05.08.2009 um 07:44 (UTC)    
Titel:

Danke für die Rückmeldung Wink und für den Hinweis Embarassed

Allerdings war es nicht der Fehler! -.-
Habe mal hier deinen verbesserten code und meinen verbesserten code eingefügt, keinerlei Unterschiede! -.-
http://muchloads.de.tl/Titel-der-neuen-Seite.htm


Was mich aber am Meisten an der Sache Aufregt, -.-
ist, dass die Tabelle mit Firefox prima angezeigt wird! -.-

Hier mal Screenshots mit Firefox und IE7
FF: http://img.webme.com/pic/m/muchloads/firefox-browser.png
IE7: http://img.webme.com/pic/m/muchloads/ie7-browser.png

Vielleicht wird dieser Hinweis helfen den Code zu verbessern!? *Falls es nicht an dem IE7-Browser liegt!?*

mfg, ML
______________
Beitrag05.08.2009 um 08:01 (UTC)    
Titel:

Hallo,

Ursache könnte sein, das Tabelle an Tabelle für den IE nicht "nahtlos" umsetzbar ist .

Versuche doch das ganze mit einer Tabelle .
Also das, was in Tabelle 1 und in Tabelle 3 ist ,
in die Tabelle 2 mit einfügen .

Einfach die <tr><td> </td></tr> der Tabelle 1 und 3 übernehmen in Tabelle 2.
Dann sollte da keine Lücke mehr für den IE zu sehen sein .

Gruß Wolfgang
______________


Zuletzt bearbeitet von 24939 am 05.08.2009, 09:01, insgesamt einmal bearbeitet
Beitrag05.08.2009 um 08:33 (UTC)    
Titel:

Danke für die Rückmeldung!

Leider hat es nichts gebracht Confused

So sieht nach deiner Beschreibung der Code aus:

Zitat:

<div align="center">
<body marginheight="0" topmargin="0" leftmargin="0" marginwidth="0" BGCOLOR="#000000">


<table cellspacing="0" cellpadding="0" width="860" height="330" border="0">
<tr>
<td background="http://img.webme.com/pic/m/muchloads/award-oben.png"> </td>
</tr>

<tr>
<td width="86" height="330" background="http://img.webme.com/pic/m/muchloads/award-links.png"> </td>

<td Width="271" height="330" background="http://img.webme.com/pic/m/muchloads/award-multimediahome.png"> <a target="_blank" href="http://www.multimediahome.de.tl"><img border="0" src="http://img.webme.com/pic/m/muchloads/award-multimediahome.png"/></a> </td>

<td width="178" height="330" background="http://img.webme.com/pic/m/muchloads/award-mitte.png"> </td>

<td width="146" height="330" background="http://img.webme.com/pic/m/muchloads/award-checked.png"> <a target="_blank" href="http://www.homepage-check.de.tl/muchloads.htm"><img border="0" src="http://img.webme.com/pic/m/muchloads/award-checked.png"/></a> </td>

<td width="179" height="330" background="http://img.webme.com/pic/m/muchloads/award-rechts.png"> </td>
</tr>

<tr>
<td background="http://img.webme.com/pic/m/muchloads/award-unten.png"> </td>
</tr>
</table>
</body></div>


Das rote habe ich versucht zu verändern *un nicht nur das* sieht dann nur noch hässlicher aus xD

Wie des jetzt aussieht, hier: http://muchloads.de.tl/Titel-der-neuen-Seite.htm

*Weitere verbesserungsvorschläge!? oO*

mfg, ML


(edit:
Hab vergessen zu sagen, dass die Tabelle auf der Home Seite: http://muchloads.de.tl/Home.htm
bei mir nach dem selben prinzip aufgebaut ist und da sind keine Makel! Confused )
______________


Zuletzt bearbeitet von muchloads am 05.08.2009, 09:36, insgesamt einmal bearbeitet
Beitrag04.10.2010 um 19:49 (UTC)    
Titel: NEUES PROBELM

Hallo ^^ ich habe hier mein Altes Thema aufgegriffen, zum Glück is es noch auf ^^

... bin wieder an einer Tabelle dran und habe ein ähnliches Probelm >.<

Hier der Code:

Code:
<div align="center">
<table width="728" height="500" background="http://img.webme.com/pic/m/muchloads/layout-bestellung.png" cellspacing="0" cellpadding="0" border="1">
    <tbody>

        <tr height="70">
            <td><a href="javascript:history.back()"><img border="0" width="720px" src="http://img.webme.com/pic/m/muchloads/zuruck.png"/></a></td>
        </tr>

        <tr height="395">
            <td width="30"></td>
            <td width="260"><a href=""><img border="0" width="260" height="395" src="http://img.webme.com/pic/m/muchloads/layout-bestellung2.png"/></a></td>
            <td width="80"></td>
            <td width="310"></td>
            <td width="48"></td>
        </tr>

        <tr height="35">
            <td>HOME...</td>
        </tr>

    </tbody>
</table>
</div>


Aber diesesmal, habe ich alle möglichkeiten ausprobiert, die mir bekannt waren, die einzige Methode die ich gefunden hab, um die Tabelle normal anzuzeigen, wäre:

Code:
<div align="center">
<table width="728" height="500" background="http://img.webme.com/pic/m/muchloads/layout-bestellung.png" cellspacing="0" cellpadding="0" border="1">
    <tbody>

        <tr height="70">

        </tr>

        <tr height="395">
            <td width="30"></td>
            <td width="260"><a href=""><img border="0" width="260" height="395" src="http://img.webme.com/pic/m/muchloads/layout-bestellung2.png"/></a></td>
            <td width="80"></td>
            <td width="310"></td>
            <td width="48"></td>
        </tr>

        <tr height="35">

        </tr>

    </tbody>
</table>
</div>


die oberen und unteren td-Tags zu entfernen, allerdings brauche ich diese xD

Wer weiß eine Lösung dazu?? oO

Gruß, Stan
______________
Beitrag04.10.2010 um 20:53 (UTC)    
Titel: sry

Kann dir leider nicht helfen xDDDD
Beitrag05.10.2010 um 13:01 (UTC)    
Titel:

^^ damit hast du mir aber auch echt nicht geholfen ^^
habe aber schon selbst'ne Lösung zu diesem seltsamen Problem gefunden ^^

Sieht im Endeffekt so aus:
http://muchloads.de.tl/order.htm

Wer den Lösungsweg sehn möchte, kann ja gern kleine Mail reinposten =)

Gruß, Stan
______________
Beiträge der letzten Zeit anzeigen:   


Powered by phpBB © 2001, 2005 phpBB Group
Deutsche Übersetzung von phpBB.de