Suche im Forum:
Suchen


« Vorheriges Thema anzeigen :: Nächstes Thema anzeigen »  
Autor Nachricht
Beitrag29.11.2011 um 19:24 (UTC)    
Titel: Button mit CK-Editor funzt nicht im IE

Hallo,

habe nach mühevoller Kleinarbeit alle verlinkten Texte durch Button ersetzt.
Diese ließen sich sehr einfach mit dem CK-Editor herstellen und dann im
Quelltext einfügen. Gleiches funzt auch mit verlinkten Bildern über den CK-Editor.
Nun habe ich Firefox und gar nicht bemerkt dass das beim IE nicht geht.
Die verlinkten Bilder lassen sich zwar im IE mit rechtsklick/ Link öffnen noch
öffnen - die Button dagegen bleiben ohne Reaktion.

Kann man da was umstellen oder haben jetzt alle mit IE Pech gehabt?

MfG Bernd


Zuletzt bearbeitet von ikarus-288 am 29.11.2011, 20:26, insgesamt einmal bearbeitet
Beitrag29.11.2011 um 21:08 (UTC)    
Titel:

Hallo,

geht es um die Buttons auf deiner Startseite?
Ich habe noch nie gesehen, dass jemand Buttons auf diese Weise verlinkt, nach der Spezifikation ist das allerdings erlaubt. Ich vermute mal, dass der IE das auch noch nicht gesehen hat, zumindest bis Version 8 im 9 er und 10er klappt es nämlich.

Einstellen, kann man das dahingehend, dass man seinen Browser aktuell hält. Was im übrigen immer empfehlenswert ist.
Verlinke den Button wie folgt, damit sollte der IE dann auch klarkommen:

Bsp:
Zitat:
<input onclick="window.location.href='Hier die URL';" type="button" value="irgendwas">


Wenn ich das richtig verstanden habe, dann klappt es mit den Bildern auch nicht? falls ja poste mal bitte den Link zu einem verlinkten Bild oder den dazugehörigen code.

- verschoben, nach: HTML & JavaScript -
______________
mfg
o-4-n

"If you’re incompetent, you can’t know you’re incompetent." - [David Dunning]

*** Die Suchfunktion ist KEINE tödliche Krankheit! ***

Eventplanung, Equipment, Zeltverleih, Catering


Zuletzt bearbeitet von o-4-n am 29.11.2011, 22:09, insgesamt einmal bearbeitet
Beitrag29.11.2011 um 21:35 (UTC)    
Titel:

Hallo,
Danke für schnelle Antwort.

Ja, es geht - aber nicht nur - auch um die Button auf der Startseite.
Die hier ... http://ikarus-288.de.tl/Lenk_-und-Ruhezeiten.htm
... gehen alle nicht unter IE.

Hier ein Link zur Seite mit 3 Bildern die verlinkt sind.
http://ikarus-288.de.tl/Stadtbusse.htm
Nur mit Rechtsklick / Link öffnen kommt man weiter ...
Ausprobiert habe ich das mit IE 7.0 - der ist bei mir drauf, nehme ich aber nicht.

Browser aktuell halten ist ein gutes Stichwort. Habe extra den 3.xxx weil in einer
höheren Version Themes Black Steel nicht geht. Außerdem sagt mein Sohn:
-"greife nie in ein funktionierendes System ein" ... Das nur mal nebenbei und tut hier weniger zur Sache - aber so geht es mir Question

Den Tipp mit den Button probiere ich demnächst mal aus.

Edit:

So, ausprobiert und das mit dem Button geht nun unter IE 7.xxx

Danke sehr, muss ich wohl nochmal ranne

Der Code für einen Bildbutton sieht so aus ...
Code:
<p>
   <input alt="" dir="ltr" src="http://img.webme.com/pic/i/ikarus-288/8507frontlinks.jpg" style="width: 180px; height: 135px; border-width: 3px; border-style: solid;" title="Hamburg" type="image" /></p>


Da kommt dann noch der Link zur Seite rein ... und auf Feuerfuchs geht das dann ...


Zuletzt bearbeitet von ikarus-288 am 29.11.2011, 22:53, insgesamt einmal bearbeitet
Beitrag29.11.2011 um 22:39 (UTC)    
Titel:

ikarus-288 hat Folgendes geschrieben:
Die hier ... http://ikarus-288.de.tl/Lenk_-und-Ruhezeiten.htm
... gehen alle nicht unter IE.

Ist genau das gleiche, wie auf der Startseite. Ich weiss jetzt nicht, ob sich dein Edit auch darauf bezogen hat, mit meinem code müsste es gehen.

ikarus-288 hat Folgendes geschrieben:
Hier ein Link zur Seite mit 3 Bildern die verlinkt sind.
http://ikarus-288.de.tl/Stadtbusse.htm

Ähnliches Problem, wie oben. Bilder verlinkt man wie folgt:
Zitat:
<a href="Ziel URL"><img src="Bild URL" alt="irgendwas"></a>

Damit dürfte auch der IE keine Probleme machen.

ikarus-288 hat Folgendes geschrieben:
Browser aktuell halten ist ein gutes Stichwort. Habe extra den 3.xxx weil in einer
höheren Version Themes Black Steel nicht geht. Außerdem sagt mein Sohn:
-"greife nie in ein funktionierendes System ein" ... Das nur mal nebenbei und tut hier weniger zur Sache - aber so geht es mir Question

Dazu will ich eigentlich nicht viel sagen, nur soviel das ist grob fahrlässig und damit meine ich nicht irgendwelche Darstellungsgeschichten sondern vorallem Sicherheitsaspekte!
______________
mfg
o-4-n

"If you’re incompetent, you can’t know you’re incompetent." - [David Dunning]

*** Die Suchfunktion ist KEINE tödliche Krankheit! ***

Eventplanung, Equipment, Zeltverleih, Catering
Beitrag30.11.2011 um 05:57 (UTC)    
Titel:

Hallo o-4-n,

Tausend Dank für Hilfe.

Also die Button funktionieren (auch unter IE) mit deinem Link. Habe ich gestern schon ausprobiert.

Die Bilderlinks probiere ich heute ... wird aber auch gehen, da bin ich mir sicher.
Habe hier immer kompetente Beratung bekommen.

Was die Version vom Feuerfuchs angeht .... werde ich nun auch aktualisieren.
Ich höre jetzt eben mal nicht auf meinen Sohn - der hat früher auch nicht auf mich gehört Mr. Green
Beitrag01.12.2011 um 08:27 (UTC)    
Titel:

Hallo o-4-n,

habe angefangen und die ersten Button ersetzt. Mit IE 7.xxx funzt das jetzt auch.
Wenn du gucken willst - auf meiner Startseite die zwei Button sind geändert.

Frage - bevor ich meine Seite zerschieße ...

Ich habe auch Button mit der Bezeichnung "Nach oben". Diese werden zwar auch verlinkt, aber nur zu einem Anker auf der selben Seite.
Nehme ich da auch den Code ?

Habe mal getestet und bei URL dann eben die von der Seite eingegeben. Gehen tut das - bei Klick springt der "Nach oben" - zu einem gesetzten Anker - war das richtig so?
Habe vorerst zwei Seiten Probeweise so gemacht.
Wenn du gucken willst - unter "50-er Jahre".
Geht auch unter IE 7.xxx - kann ich so weiter machen?

Nächste Sache - die verlinkten Bilder muss ich auch alle ersetzen. Habe mal eins unter "Stadtbusse" / "Hamburg" ersetzt. Geht auch unter IE 7.xxx

Würde dann so weiter machen wenn du mir das so bestätigen kannst.

Grüße aus dem Barnim

MfG Bernd
Beitrag01.12.2011 um 11:42 (UTC)    
Titel:

Hallo,

was die Anker angeht, kannst du auch den Code verwenden. Wenn mich nicht alles täuscht, musst du aber nicht die komplette URL angeben, der Name des Ankers mit # reicht aus:
Zitat:
<input onclick="window.location.href='#Name des Ankers';" type="button" value="irgendwas">


Das Bild ist Ok.
______________
mfg
o-4-n

"If you’re incompetent, you can’t know you’re incompetent." - [David Dunning]

*** Die Suchfunktion ist KEINE tödliche Krankheit! ***

Eventplanung, Equipment, Zeltverleih, Catering
Beitrag02.12.2011 um 08:13 (UTC)    
Titel:

Ich Danke dir - endlich mal eine gute Nachricht.

Wünsche noch schöne Vorweihnachtstage ....

MfG Bernd
Beitrag02.12.2011 um 23:02 (UTC)    
Titel:

Dann danke für die Rückmeldung. Smile

- CLOSED -
______________
mfg
o-4-n

"If you’re incompetent, you can’t know you’re incompetent." - [David Dunning]

*** Die Suchfunktion ist KEINE tödliche Krankheit! ***

Eventplanung, Equipment, Zeltverleih, Catering
Beiträge der letzten Zeit anzeigen:   


Powered by phpBB © 2001, 2005 phpBB Group
Deutsche Übersetzung von phpBB.de