Suche im Forum:
Suchen


« Vorheriges Thema anzeigen :: Nächstes Thema anzeigen »  
Autor Nachricht
Beitrag16.01.2013 um 16:14 (UTC)    
Titel: Horizontales Menü Fehler beim Internet Explorer

Guten Tag,

ich habe auf der Website schon seit längerem eine horizontale Navigation.
Ich verwende Mozilla Firefox und habe kürzlich festgestellt, dass die Navigation beim Internet Explorer garnicht angezeigt wird.

An was kann das liegen?
Wie könnte man den Fehler beheben?

Zitat:
/* Feld für das Menu */
#Menu_Box {
width: 650px; /* Breite */
position: absolute;
left: 50%; /* = NICHT ÄNDERN ! */
margin-left: -460px; /* nach LINKS + RECHTS verschieben */
margin-top: 15px; /* nach OBEN + UNTEN verschieben */
overflow: hidden;}

/* die 4 DIV Felder */
#link_1, #link_2, #link_3, #link_4 {
float: left; /* Buttons nebeneinander */
text-align: center;
margin-right: 8px; /* Abstand zwischen Buttons */
overflow: hidden; }

/* das Aussehen der 4 Links */
#link_1 a, #link_2 a, #link_3 a, #link_4 a {
display: block; /* = Verlinkung füllt Feld aus */
width: 88px; /* = Breite des Button */
height: 45px; /* = Höhe des Button */
line-height:52px; /* = muss Höhe bekommen, die auch height hat */
margin-top: 52px; /* = nur notwendig, wenn Hover-Effekt verwendet wird */
color: #cccccc; /* = Linkfarbe */
font-size: 14px; /* = Link Textgroeße */
font-family: arial; /* = Link Schriftart */
text-decoration: none; /* = Link nicht unterstrichen */
background-color: #555555; /* = Hintergrundfarbe Link */
background-image:url(http://img.webme.com/pic/m/mhw-cube-racing-team/nav_oben_2012.jpg);
-webkit-border-top-left-radius: 10px;
-webkit-border-top-right-radius: 10px;
border-top-left-radius: 10px;
border-top-right-radius: 10px;}


/* Der Hover Effekt fuer die Links */
#link_1 a:hover, #link_2 a:hover, #link_3 a:hover, #link_4 a:hover {
font-size:15px;
margin-top: 52px;
padding-top: 0px;
padding-bottom: 0px;
color: #ffffff;
background-image:url(http://img.webme.com/pic/m/mhw-cube-racing-team/nav_oben_2012-hover.jpg);
background-color: #6f8ac4; }




<div id="Menu_Box">
<div id="link_1"> <a href="http://mhw-cube-racing-team.de/News.htm">News</a> </div>
<div id="link_2"> <a href="http://mhw-cube-racing-team.de/Team.htm">Team</a> </div>
<div id="link_3"> <a href="http://mhw-cube-racing-team.de/Media.htm">Media</a> </div>
<div id="link_4"> <a href="http://mhw-cube-racing-team.de/Sponsoren.htm">Sponsoren</a> </div>
</div>





Vielen Dank für die Antworten![/quote]


Zuletzt bearbeitet von mhw-cube-racing-team am 16.01.2013, 18:11, insgesamt einmal bearbeitet
Beitrag06.02.2013 um 11:58 (UTC)    
Titel:

Abgesehen davon, dass man eine Navigation HTML, und CSS technisch ein wenig anders macht, muss ich sagen, dass es bei mir im IE genauso funktionert wie im Firefox oder Google Chrome
Beitrag06.02.2013 um 12:45 (UTC)    
Titel:

kraffix hat Folgendes geschrieben:
Abgesehen davon, dass man eine Navigation HTML, und CSS technisch ein wenig anders macht, muss ich sagen, dass es bei mir im IE genauso funktionert wie im Firefox oder Google Chrome


je nach version des browsers. internetexplorer 8 (windows xp) gibt es auch keine navigation.

gruss gringo
______________
Mein Youtube Kanal | Standard-Designs als Red Design ohne rechte Boxen | Tips zum Design Professionell

Beitrag06.02.2013 um 13:58 (UTC)    
Titel:

Hallo,

Ursache ist folgendes :

Dein #Menu_Box enthält Eigenschaften, um es auf das Design zu platzieren.
Da wir ein externes Menü nicht zum Inhalt der Seite machen können.

Nun hast Du aber im Feld "Text über Design" ein DIV um dein Design gelegt.
Zitat:

<div style="width:921px; margin: 0px auto; overflow:hidden; position:relative;">


Damit ist dein Menü nun Inhalt eines Elementes.
Die Positionierung stimmt nun nicht mehr.
Nun müssen wir bei der Positionierung vom DIV ausgehen, das es umgibt.

Probiere folgende Änderung

Zitat:

/* Feld für das Menu */
#Menu_Box {
position:absolute;
width: 650px;
margin-left: 0px;
margin-top:10px;
overflow: hidden;}


Du müsstest eventuell margin-top noch anpassen .Wink

Gruß Wolle


Zuletzt bearbeitet von find-templates am 06.02.2013, 15:07, insgesamt 3-mal bearbeitet
Beitrag06.02.2013 um 16:42 (UTC)    
Titel:

Hallo Wolle,

vielen Dank für die Antwort!
Beitrag06.02.2013 um 18:19 (UTC)    
Titel:

gern geschehen,

das (alte) Tutorial auf iceblue-test.de.tl habe ich durch ein neues ersetzt.
Mit den DIV's war es einwenig unglücklich, es war aber auch schon 3 Jahre alt.

Gruß Wolle
Beiträge der letzten Zeit anzeigen:   


Powered by phpBB © 2001, 2005 phpBB Group
Deutsche Übersetzung von phpBB.de