Suche im Forum:
Suchen


Autor Nachricht
Beitrag14.01.2015 um 14:39 (UTC)    
Titel: Script verschiebt Slider & Seiteninhalt

Hallo zusammen.
Ich kämpfe mit einem ärgerlichen Problem.

Als Like & Sharing Codes verwende ich AddThis, diese bieten einen "Newsbalken" an welcher ganz Oben bei der Seite angezeigt wird. Durch das Dynamische "herunterfahren" verschiebt sich aber leider auch der Slider und der Seiteninhalt.
(Teils benötigt es ein Reload der Seite)

1. Daher meine Frage, was könnte ich ändern das dies nicht mehr geschieht?

Kleine Fragen nebenbei:
2. Wo finde ich die Einstellung um den Slider grundsätzlich näher an das Menu zu bringen?
3. Es scheint als hätte ich bereits vor Problem Nr. 1 ein Scriptproblem. Oder woher kommt das "//--> " in der linken Ecke? Embarassed

Ich danke für jede Hilfe welche ich erhalte herzlichst!
unbekannt270
______________
Nein, du darfst keine Bilder von Google verwenden! Kostenlose Bilder für deine Homepage gibt`s hier:

Beitrag16.01.2015 um 08:11 (UTC)    
Titel:

Moinsen,
ein "verschieben" des Inhalts konnte ich jetzt so nicht feststellen. Vielleicht musst du das etwas näher erklären und / oder nen Screenie machen.

Allerdings solltest du dir diese Zeilen mal anschauen, hier haben sich ein "paar" Fehler eingeschlichen u.a. die Zeichenkette links oben in der Ecke.
Bei Text ÜBER dem Design sollte das drin sein:
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-52f2563b7109df30"></script> //-->
Wenn du den roten Teil entfernst, dann sind schonmal die Zeichen weg.

Dann bin ich mir nicht sicher, ob das auch bei dir im Text ÜBER dem Design steht.
</style>
Sollte sozusagen als Letztes dort stehen, falls ja, raus damit Mr. Green

Das hier
<link rel="stylesheet" href="http://www.ombadesign.de/designs/fotografie/nivo-slider.css" type="text/css" media="screen" />
<link rel="stylesheet" href="http://www.ombadesign.de/designs/fotografie/themes/bar/bar.css" type="text/css" media="screen" />
<link href='http://fonts.googleapis.com/css?family=Unica+One|Duru+Sans|Montez' rel='stylesheet' type='text/css'>
sollte nicht im <body> stehen sondern im Header => da gibt es ein Extra dafür und / oder du baust es an letzter Stelle in Text ÜBER dem Design.

Und dann gibt es noch einen unnützen <div> Container.
<div id="navi_links">
<ul>
</div>
Der Container ansich kann ja bleiben, aber das öffnende <ul> ist hier unnütz, da es ja "nichts macht" und auch nur "geöffnet" wird. Also raus damit. Mr. Green
______________
mfg SEO
---
Ist ein Thema von dir erledigt, dann schreib das [erledigt] doch BITTE auch in den Titel des ersten Postings rein!
Verwendet sinnvolle und beschreibende Titel. Wer kann mir helfen ... oder Hilfe... sind nur bedingt hilfreich!
Doppelpostings quer durchs Forum finden übrigens nicht nur Moderatoren doof!
Themenfremde Posting in den verschiedenen Kategorien sind ebenso doof und schaffen nur unnötige Arbeit!
Beitrag17.01.2015 um 23:37 (UTC)    
Titel:

Heyho SEO!
Erstmal vielen Dank für Deine Mühe - nicht zum ersten Mal!
Gerne gebe ich Dir eine Rückmeldung zu deinen Tipps.

seo-suchmaschinenoptimierung hat Folgendes geschrieben:
Moinsen,
ein "verschieben" des Inhalts konnte ich jetzt so nicht feststellen. Vielleicht musst du das etwas näher erklären und / oder nen Screenie machen.

Gerne. Auf Bild 1 ist der Normalzustand zu sehen. Auf Bild 2 ist zu erkennen, das mit dem Infobalken auch der ganze Seiteninhalt "verrutscht" ist. Und zwar genau +/- in der Grösse des Balkens.
Bild 1: http://img.webme.com/pic/u/unbekannt270/verschieben1.png
Bild 2: http://img.webme.com/pic/u/unbekannt270/verschieben2.png

seo-suchmaschinenoptimierung hat Folgendes geschrieben:

Bei Text ÜBER dem Design sollte das drin sein:
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-52f2563b7109df30"></script> //-->
Wenn du den roten Teil entfernst, dann sind schonmal die Zeichen weg.
Konnte den Fehler ausfindig machen. Ein </style> in "CSS-Code
ohne Style Tags" (Embarassed) löste den Fehler aus.


seo-suchmaschinenoptimierung hat Folgendes geschrieben:

Dann bin ich mir nicht sicher, ob das auch bei dir im Text ÜBER dem Design steht.
</style>
Ist drin.

seo-suchmaschinenoptimierung hat Folgendes geschrieben:

Das hier
<link rel="stylesheet" href="http://www.ombadesign.de/designs/fotografie/nivo-slider.css" type="text/css" media="screen" />
<link rel="stylesheet" href="http://www.ombadesign.de/designs/fotografie/themes/bar/bar.css" type="text/css" media="screen" />
<link href='http://fonts.googleapis.com/css?family=Unica+One|Duru+Sans|Montez' rel='stylesheet' type='text/css'>
sollte nicht im <body> stehen sondern im Header => da gibt es ein Extra dafür und / oder du baust es an letzter Stelle in Text ÜBER dem Design.

Mit beiden Versionen steht die Homepage oder bzw. deren Grafikelemente ect. kopf.. Wink

seo-suchmaschinenoptimierung hat Folgendes geschrieben:

Und dann gibt es noch einen unnützen <div> Container.
<div id="navi_links">
<ul>
</div>
Der Container ansich kann ja bleiben, aber das öffnende <ul> ist hier unnütz, da es ja "nichts macht" und auch nur "geöffnet" wird. Also raus damit. Mr. Green

Gefunden und beseitigt.
Vielen Dank bis jetzt SEO! Hoffe das andere Promblem kann auch noch beseitigt werden Smile

______________
Nein, du darfst keine Bilder von Google verwenden! Kostenlose Bilder für deine Homepage gibt`s hier:

Beitrag21.01.2015 um 08:07 (UTC)    
Titel:

unbekannt270 hat Folgendes geschrieben:
Heyho SEO!
seo-suchmaschinenoptimierung hat Folgendes geschrieben:
Moinsen,
ein "verschieben" des Inhalts konnte ich jetzt so nicht feststellen. Vielleicht musst du das etwas näher erklären und / oder nen Screenie machen.

Gerne. Auf Bild 1 ist der Normalzustand zu sehen. Auf Bild 2 ist zu erkennen, das mit dem Infobalken auch der ganze Seiteninhalt "verrutscht" ist. Und zwar genau +/- in der Grösse des Balkens.
Bild 1: http://img.webme.com/pic/u/unbekannt270/verschieben1.png
Bild 2: http://img.webme.com/pic/u/unbekannt270/verschieben2.png

Moinsen,
sorry, dauert gerade immer etwas, bis mal 'ne Antwort kommt. Hab' gerade etwas viel um die Ohren.

Dank der Screenies habe ich das Problem jetzt auch verstanden. Manchmal brauche ich das eben visuell Mr. Green
Der Inhalt verschiebt sich um genau die Pixelzahl nach unten, die vom Infobalken oben genutzt wird ....
Wann genau wird denn der Infobalken immer angezeigt? Ich hatte den nur einmal zu sehen bekommen und dummerweise weggeklickt ...
Aber ich kann zumindest schon mal behaupten, das muss irgendwie am position: fixed und / oder position: absolute liegen, welches bei addthis auf die class .addthis_bar.addthis_bar_top angewendet wird. Das wir "etwas" schwierig, das zu "debuggen", da das Script ja nicht hier rumliegt, sondern dort.
______________
mfg SEO
---
Ist ein Thema von dir erledigt, dann schreib das [erledigt] doch BITTE auch in den Titel des ersten Postings rein!
Verwendet sinnvolle und beschreibende Titel. Wer kann mir helfen ... oder Hilfe... sind nur bedingt hilfreich!
Doppelpostings quer durchs Forum finden übrigens nicht nur Moderatoren doof!
Themenfremde Posting in den verschiedenen Kategorien sind ebenso doof und schaffen nur unnötige Arbeit!
Beitrag22.01.2015 um 17:12 (UTC)    
Titel:

seo-suchmaschinenoptimierung hat Folgendes geschrieben:
unbekannt270 hat Folgendes geschrieben:
Heyho SEO!
seo-suchmaschinenoptimierung hat Folgendes geschrieben:
Moinsen,
ein "verschieben" des Inhalts konnte ich jetzt so nicht feststellen. Vielleicht musst du das etwas näher erklären und / oder nen Screenie machen.

Gerne. Auf Bild 1 ist der Normalzustand zu sehen. Auf Bild 2 ist zu erkennen, das mit dem Infobalken auch der ganze Seiteninhalt "verrutscht" ist. Und zwar genau +/- in der Grösse des Balkens.
Bild 1: http://img.webme.com/pic/u/unbekannt270/verschieben1.png
Bild 2: http://img.webme.com/pic/u/unbekannt270/verschieben2.png

Moinsen,
sorry, dauert gerade immer etwas, bis mal 'ne Antwort kommt. Hab' gerade etwas viel um die Ohren.

Dank der Screenies habe ich das Problem jetzt auch verstanden. Manchmal brauche ich das eben visuell Mr. Green
Der Inhalt verschiebt sich um genau die Pixelzahl nach unten, die vom Infobalken oben genutzt wird ....
Wann genau wird denn der Infobalken immer angezeigt? Ich hatte den nur einmal zu sehen bekommen und dummerweise weggeklickt ...
Aber ich kann zumindest schon mal behaupten, das muss irgendwie am position: fixed und / oder position: absolute liegen, welches bei addthis auf die class .addthis_bar.addthis_bar_top angewendet wird. Das wir "etwas" schwierig, das zu "debuggen", da das Script ja nicht hier rumliegt, sondern dort.

Hallo SEO.
Vielen Dank das Du dir trotzdem die Zeit nimmst mir zu helfen! Auf den Anzeigeyklus habe ich leider keinen Einfluss. Ich vermute aber, das er bis zum betätigen der "wegklick" Option sichtbar bleibt. Das ganze Problem wäre ja nicht so schlimm, hätte ich nicht generell eine zu grosse Lücke zwischen dem Slider und dem Menu. Weisst Du dafür eventuell auch einen Rat? Der ganze Slider inkl. Umramung sollte näher zum Menu. Somit würde beim Infobalken auch nicht ein so grosses Loch klaffen..

Ich verbleibe mit einem riesigen Dankeschön!
______________
Nein, du darfst keine Bilder von Google verwenden! Kostenlose Bilder für deine Homepage gibt`s hier:

Beitrag23.01.2015 um 00:41 (UTC)    
Titel:

Hallo

ein Javascript-Code hat sich noch mitten in deinen CSS Code verirrt.
Ich habe ihn mal grün markiert im Screen :http://img.webme.com/pic/c/clean-test/screen.png

dazu ein Kleiner Tipp Very Happy
Du hast das Baukasten-Design "CSS". Dort hast Du das Feld "css ohne style tags".
Füge dort bitte ALLE CSS-Codes ein, auch die aus dem Feld "Text über Design", aber ohne "style-tags"

Und im Feld "Text ÜBER Design" fügst Du ein :

- die externen CSS-Codes
- dann die .js Dateien und Javascripte
- dann dürfen die DIV's folgen von Deinem Slider
- diese Reihenfolge bitte einhalten

Zur Lösung mit dem Infobalken, der den Inhalt nach unten verschiebt :
Im Quellcode fand ich einen leeren Platzhalter mit der Höhe 46 Pixel, welches deinen Inhalt nach unten rücken lässt.

Zitat:

div.addthis_bar_placeholder{ height:10px!important; }


Habe die Höhe mal auf 10 Pixel geändert. Das sollte wieder passen.

Gruß Wolle
Beiträge der letzten Zeit anzeigen:   


Powered by phpBB © 2001, 2005 phpBB Group
Deutsche Übersetzung von phpBB.de