Suche im Forum:
Suchen


« Vorheriges Thema anzeigen :: Nächstes Thema anzeigen »  
Autor Nachricht
Beitrag01.06.2010 um 05:51 (UTC)    
Titel: erledigt-Hintergrund nur auf Startseite

Guten morgen,

Edit: Baukastenstyle-Butterfly

ich habe als Hintergrund ein Bild gewählt. Dies erscheint auch, wenn ich die Seite erstmalig aufrufe. Wechsle ich jedoch zu einer anderen Seite der HP, ist der Hintergrund grau.

Das ist der relevante Teil des Codes:
div#DesignContainer{position:absolute;left:50%;margin-left:-500px;width:1000px;text-align:center;}td[height="102"]{position:absolute;left:50%;margin-left:-376px;width:752px;}body{background-image:url(http://www.imgbox.de/users/akiralea/Pfoten12.jpg);background-color:#bbbbbb;background-attachment:fixed;background-repeat:repeat;background-position:center;}

Was ist falsch?
Ich hätte den Hintergrund natürlich gerne auf allen Seiten....

Danke für die Tipps
LG
Marion


Zuletzt bearbeitet von akiralea am 02.06.2010, 05:47, insgesamt 2-mal bearbeitet
Beitrag01.06.2010 um 08:52 (UTC)    
Titel:

möglicher weise hast du im code noch einen fehler.

--> das hier ist bei deiner seite oben links zu sehen und sollte aber nicht. du müsstest den ganzen code mal hier posten, der bei text über dem design steht.

gruss gringo
______________
Mein Youtube Kanal | Standard-Designs als Red Design ohne rechte Boxen | Tips zum Design Professionell

Beitrag01.06.2010 um 10:31 (UTC)    
Titel:

Gerne Smile

-->
</style>
<table align="center" cellpadding=0 cellspacing=0 border=0><tr><td align="center">
<style type="text/css">
<!--
<div id="DesignContainer"><script language="JavaScript" src="http://js.stats.de/j/0000092624"></script><script language="JavaScript">rapidstats(92624);</script><noscript><a href="http://www.stats.de" target="_blank"> <img src="http://srv1.stats.de/l/0000092624?js=0" border="0" alt=""></a></noscript><style type="text/css"><!-- //* Generated by www.design-generator.de.tl */ div#DesignContainer{position:absolute;left:50%;margin-left:-500px;width:1000px;text-align:center;}td[height="102"]{position:absolute;left:50%;margin-left:-376px;width:752px;}body{background-image:url(http://www.imgbox.de/users/akiralea/Pfoten12.jpg);background-color:#bbbbbb;background-attachment:fixed;background-repeat:repeat;background-position:center;}td.edit_header{background-repeat:no-repeat;background-image:url(http://www.imgbox.de/users/akiralea/header_neu2.jpg);}td.edit_nav_main{background-image: url(http://www.imgbox.de/users/akiralea/Button_weiss.gif);background-color:transparent;}td.cont,td.cont_bar_left{background-image: none;background-color:#f5f5f5;}a.menu,a.menu:hover{color:#FF6600;font-family:Comic Sans MS;font-size:14px;}
-->
</style>

<style type="text/css">
<!--
a:link{color:#E50000;font-size:14px}a:visited{color:#333333;font-size:14px}a:active{color: #FFFF00;font-size:14px}a:hover{color:#ff4c00;font-size:14px}
-->
</style>
<style type="text/css">
<!--
td.edit_right_box{background-image:url(); background-color:#555555;}
-->
</style>
Beitrag01.06.2010 um 13:18 (UTC)    
Titel:

Hallo,
lösch mal bitte alles bei "Text über dem Design" und füge dann folgenden Code ein:
Zitat:
<div id="DesignContainer">
<script language="JavaScript" src="http://js.stats.de/j/0000092624"></script><script language="JavaScript">rapidstats(92624);</script><noscript><a href="http://www.stats.de" target="_blank"> <img src="http://srv1.stats.de/l/0000092624?js=0" border="0" alt=""></a></noscript>

<style type="text/css"><!-- //* Generated by www.design-generator.de.tl */ div#DesignContainer{position:absolute;left:50%;margin-left:-500px;width:1000px;text-align:center;}td[height="102"]{position:absolute;left:50%;margin-left:-376px;width:752px;}body{background: url(http://www.imgbox.de/users/akiralea/Pfoten12.jpg) #bbbbbb fixed repeat;background-position:center;}td.edit_header{background-repeat:no-repeat;background-image:url(http://www.imgbox.de/users/akiralea/header_neu2.jpg);}td.edit_nav_main{background-image: url(http://www.imgbox.de/users/akiralea/Button_weiss.gif);background-color:transparent;}td.cont,td.cont_bar_left{background-image: none;background-color:#f5f5f5;}a.menu,a.menu:hover{color:#FF6600;font-family:Comic Sans MS;font-size:14px;}
a:link{color:#E50000;font-size:14px}a:visited{color:#333333;font-size:14px}a:active{color: #FFFF00;font-size:14px}a:hover{color:#ff4c00;font-size:14px}
td.edit_right_box{background-image:url(); background-color:#555555;}
-->
</style>
mfg Dominik
______________
Besucht die offizielle Hilfeseite vom Homepage-Baukasten:

Iceblue Generator | Red Generator | Butterfly Generator
Beitrag01.06.2010 um 15:28 (UTC)    
Titel:

Danke, habe ich gemacht. Beim FF hatte ich das Problem mit dem Hintergrundbild nicht, nur beim IE...und wenn ich da jetzt schaue, ist nur noch das Mittelteil da....geht also nicht.

Und den Teil
-->
</style>
<table align="center" cellpadding=0 cellspacing=0 border=0><tr><td align="center">
<style type="text/css">
<!--

muss ich auch drinne lassen, sonst ist das style nicht zentriert...auch beim FF.

Und sobald das drin ist, habe ich auch den Pfeil wieder auf der Seite...*grummel*

Was nun?


Edit: den Pfeil oben links hab ich weg...durch löschen von dem hier
-->
</style> am Beginn
Es steht also jetzt nur noch das drin:
<table align="center" cellpadding=0 cellspacing=0 border=0><tr><td align="center">
<style type="text/css">
<!--


Beim IE ist das ganze jetzt UNTEREINANDER...oben Hintergrund und Startseite und unten kommen die Boxen und der Kram. Hilfe...jetzt ist scheinbar alles hin....Ich habe den alten Text wieder eingesetzt.


Zuletzt bearbeitet von akiralea am 01.06.2010, 16:54, insgesamt 3-mal bearbeitet
Beitrag01.06.2010 um 16:09 (UTC)    
Titel:

So, jetzt habe ich folgendes erreicht: der Pfeil oben links ist weg.

Beim IE wird beim ersten Öffnen der Seite auch das Hintergrundbild angezeigt. Klicke ich auf eine andere Seite, ist der Hintergrund grau.
Beim FF ist das Bild immer da, auf allen Seiten. Steht der Code mit dem Hintergrundbild vielleicht an einer falschen Stelle im Text?

Ich hab ja keine Ahnung von CSS und bin froh, dass die Seite überhaupt geht Very Happy


Beim FF ruckelt die ganze HP ab und zu, d.h. die Seitenränder oder was auch immer weichen voneinander ab, als würde sich die HP erst mal zentrieren oder so...vielleicht hat es ja auch damit was zu tun??? Sorry, ich hoffe, ihr wisst, was ich meine, weiß nicht genau, wie das alles in Profisprache heißt...


Zuletzt bearbeitet von akiralea am 01.06.2010, 17:11, insgesamt einmal bearbeitet
Beitrag01.06.2010 um 16:26 (UTC)    
Titel:

Code:


<style type="text/css">
<!--
<table align="center" cellpadding=0 cellspacing=0 border=0><tr><td align="center">
-->
</style>



schon so versucht mit dem mittig machen? bei deinem code kommt mir die reihenfolge der styletags so seltsam vor.

hast du bei text unter dem design auch was drin stehen?

gruss gringo
______________
Mein Youtube Kanal | Standard-Designs als Red Design ohne rechte Boxen | Tips zum Design Professionell



Zuletzt bearbeitet von 6p-iceblue am 01.06.2010, 17:30, insgesamt 2-mal bearbeitet
Beitrag01.06.2010 um 17:11 (UTC)    
Titel:

Jupp, untendrunter steht das hier:
</td></tr></table>

Deinen Text habe ich grade ausprobiert...steht alles wieder linksbündig statt mittig.
Wenn ich mich recht erinnere, war das der Text, den ich zuerst auch probiert hatte und der ging nicht. Dann hab ich im Forum gestöbert und den Text gefunden, den ich dann bei mir eingestellt habe. Der ging dann.
Beitrag01.06.2010 um 17:15 (UTC)    
Titel:

hmmm, schon alles seltsam. aber vielleicht lautet der befehl des mittig machens anders als beim iceblue.

aber ich denke, das es der auslöser deines problems für das hintergrundbild ist.

gruss gringo
______________
Mein Youtube Kanal | Standard-Designs als Red Design ohne rechte Boxen | Tips zum Design Professionell

Beitrag01.06.2010 um 17:23 (UTC)    
Titel:

Du hast recht. Ich habe den Text fürs zentrieren und den Text unter dem Design weggemacht. Und schwupp...das Hintergrundbild ist im IE auf jeder Seite sichtbar....soweit so gut, vielen Dank für den Tipp.

Aaaaber, wie bekomme ich das verdammte Ding nun mittig?

Werde nochmal im Forum rumforsten, vielleicht find ich ja was.

Falls jemand weiß, wie es geht...her damit Laughing
Beitrag01.06.2010 um 17:26 (UTC)    
Titel:

HAH, ich habs gefunden!!!!!!
http://www.homepage-baukasten.de/forum/viewtopic.php?t=109732&highlight=butterfly+zentrieren



Daaaanke allen, die mir zur Lösung verholfen haben.

LG
Marion
Beitrag01.06.2010 um 17:28 (UTC)    
Titel:

mit geduld und spucke wird alles gut Wink

gruss gringo

ich finds super das du dich nicht entmutigen lässt und auch selbst was versuchst, um das problem zu lösen.
______________
Mein Youtube Kanal | Standard-Designs als Red Design ohne rechte Boxen | Tips zum Design Professionell



Zuletzt bearbeitet von 6p-iceblue am 01.06.2010, 18:29, insgesamt einmal bearbeitet
Beitrag01.06.2010 um 17:32 (UTC)    
Titel:

Joooo, bin halt eine Kämpfernatur Laughing Laughing Laughing
Aber eines hab ich aufgegeben...ein eigenes Design zu coden. Dafür muss man dann doch wissen, was man da macht. Ist gar nicht so einfach, wenn man mit 38 Jahren erstmalig eine HP haben will und sich nie damit beschäftigt hat.

Habe Stunden damit zugebracht und NICHTS auf die Beine gestellt.
Beitrag01.06.2010 um 17:35 (UTC)    
Titel:

dein design ist leider auch sehr schwer zu ändern. iceblue wäre die bessere lösung.

gruss gringo


lol, ich hab auch erst mit 45 oder so, angefangen.
______________
Mein Youtube Kanal | Standard-Designs als Red Design ohne rechte Boxen | Tips zum Design Professionell

Beitrag01.06.2010 um 17:41 (UTC)    
Titel:

Ich habe noch eine 2. "Übungs-HP".
Mal sehn, vielleicht nehm ich mir das Ice-blue ja mal vor und guck, was ich da rausholen kann...übertragen hab ich es dann ja schnell.

Merci für den Tipp.

Najaaa, wenn du ja auch erst so spät angefangen hast, darf ich ja noch Hoffnung haben Laughing
Beiträge der letzten Zeit anzeigen:   


Powered by phpBB © 2001, 2005 phpBB Group
Deutsche Übersetzung von phpBB.de