Suche im Forum:
Suchen


« Vorheriges Thema anzeigen :: Nächstes Thema anzeigen »  
Autor Nachricht
Beitrag04.07.2012 um 16:11 (UTC)    
Titel: (jQuery) Preloader funktioniert nicht.


Hey hey,

so hab da mal ne frage an die Programmierer bzw. Javascript und jQuery kenner und deren Erfahrungen mit dem HPBK.


Also mein Problem:
Ich versuche seit fast zwei Stunden, ein kleines "jQuery-Bilder-Preoloader-Script"
hier im HPBK zum laufen zu bringen.


Mein jQuery-Script sieht ziemlich genau so aus.

Code:
var loader = "<img src=\"load.gif\" class=\"load\" alt=\"Lädt…\" />";
$(document).ready(function() {
   $('.image').hide();
   $('.image_frame').append(loader);
   $(window).load( function() {
      $('.load').hide();
      $('.image').fadeIn('slow');
   });
});


Und das HTML Gegenstück so:
Zitat:
<div class="image_frame">
<a href="http://bild.de/Grafik.jpg">
<img src="http://bild.de/Grafik.jpg" width="240" height="160" class="image" alt="" />
</a>
</div>


Die dazugehörigen CSS Klassen habe ich natürlich auch eingebunden.

So dies war es eigentlich auch schon.
Lokal läuft das ganze wunderbar. Nur hier im HPBK irgendwie nicht.
Wichtig! Ich habe bereits andere jQuery-Scripte im HPBK am laufen.
Also meine frage:
Wieso? Weshalb? Warum?

Ich hoffe es kann mir einer Helfen.


lg Solvee


Zuletzt bearbeitet von solee am 04.07.2012, 17:12, insgesamt einmal bearbeitet
Beitrag05.07.2012 um 18:10 (UTC)    
Titel:

Guten Abend,
welche Version von JQuery hast du eingebunden? Es kann gut sein, dass bei den alten Versionen, gewisse Ressourcen noch nicht mit beinhaltet sind, welche du verwendest.


Grüße,
Mats
Beitrag05.07.2012 um 22:20 (UTC)    
Titel: Erledigt

Hey,
erst einmal danke für die Hilfe und Antwort.
Habe aber nun eine Lösung gefunden. Mit der ich sogar noch mehr zufrieden bin.

Tehma kann nun gerne geschlossen werden.


Solee
Beiträge der letzten Zeit anzeigen:   


Powered by phpBB © 2001, 2005 phpBB Group
Deutsche Übersetzung von phpBB.de